Downgrade dan Install versi LiteSpeed

Published on October 4, 2017, by in Tutorial.

Misal mau downgrade dari 5.1.17 ke 5.1.13, gunakan perintah ;

/usr/local/lsws/admin/misc/lsup.sh -f -v 5.1.13

Intinya perintah tersebut digunakan install LiteSpeed dengan versi tertentu yang kita  tentukan. Yang tentunya bisa digunakan juga untuk install LiteSpeed versi terbaru saat ini yaitu LiteSpeed Versi 5.2.1

Maka kita gunakan perintah :

/usr/local/lsws/admin/misc/lsup.sh -f -v 5.2.1

Demikian tulisan singkat ini, semoga bermanfaat.

Blokir semua situs di MikroTik kecuali situs tertentu

Published on September 25, 2017, by in Tutorial.

Mungkin judulnya kepanjangan ya, tapi emang ini catatan untuk Blokir semua situs di MikroTik kecuali situs tertentu.

Cara yang biasa digunakan yaitu menggunakan Layer 7 Protocol atau proxy, tapi kali ini kita hanya menggunakan fungsi Filter pada mikrotik. Cara ini digunakan karena cukup ringan digunakan pada mikrotik versi berapapun.

Konsepnya disini adalah hanya wesite google yang dijikan dan menutup semua akses pada komputer dengan ip 192.168.1.2

Kita buka mikrotik, langsung ke menu :

IP -> Firewall -> Filter Rules

Kemudian ikuti petunjuk firewall berikut :

/ip firewall filter add chain=forward dst-port=80 src-address=192.168.1.2 dst-address=74.125.200.103 protocol=tcp action=accept

/ip firewall filter add chain=forward dst-port=443 src-address=192.168.1.2 dst-address=74.125.200.103 protocol=tcp action=accept

/ip firewall filter add chain=forward dst-port=80 src-address=192.168.1.2 protocol=tcp action=drop

/ip firewall filter add chain=forward dst-port=443 src-address=192.168.1.2 protocol=tcp action=drop

Keterangan :

  • 192.168.1.2 adalah ip lokal komputer target
  • 74.125.200.103 adalah ip address publik situs tertentu yang akan dibuka

Kemudian test pada komputer yang memiliki ip lokal 192.168.1.2 tersebut. Selamat anda berhasil .. hehe.

Install cPanel DNSONLY

Published on September 20, 2017, by in Tutorial.

Untuk menginstal cPanel DNSONLY, lakukan langkah-langkah berikut:

Untuk membuka direktori / home, jalankan perintah berikut:

cd /home

Untuk mengambil file instalasi terbaru dari server cPanel, jalankan perintah berikut:

curl -o latest-dnsonly -L https://securedownloads.cpanel.net/latest-dnsonly

Untuk membuka dan menjalankan file penginstalan, jalankan perintah berikut:

sh latest-dnsonly

Demikian, semoga bermanfaat.

Referensi : https://documentation.cpanel.net/display/ALD/Installation+Guide+-+cPanel+DNSONLY+Installation

Enable Remote MySQL cPanel dengan CSF

Published on September 18, 2017, by in Tutorial.

Remote MySQL terkadang dibutuhkan untuk proses tertentu. Pada Server cPanel fasilitas ini sudah tersedia dan kita tinggal mengaktifkannya dengan menambahkan IP Publik yang kita inginkan pada menu Remote MySQL.

Pade Server cPanel yang menggunakan ConfigServer Security & Firewall, kita harus melakukan menambahkan 2 hal pada CSF yang kita gunakan. Kedua hal tersebut yaitu :

Membuka port MySQL di Firewall

Manambahkan IP Publik pada whitelist di CSF

Untuk membuka port MySQL di Firewall CSF, kita masuk ke cPanel pada menu ConfigServer Security & Firewall -> ConfigServer Firewall->Firewall Configuration->IPv4Port Settings

Tambahkan Port 3306 Pada TCP_IN, kemudian restart CSF.

Langkah selanjutnya yaitu menambahkan IP Publik pada whitelist CSF

Demikian tutorial singakt ini, semoga bermanfaat.

CSF Block FTP Filezilla

Published on September 16, 2017, by in Tutorial.

Permasalahan pada ConfigServer Security & Firewall salahsatunya yaitu port FTP terblokir, untuk bisa menggunakan FTP tersebut kita harus Temporary Allow IP yang kita gunakan untuk proses Transfer file tersebut. Hanya saja untuk IP Publik yang ada di Indonesia yang memiliki tingkat DHCP yang luar biasa genitnya, karna sebentar-bentar ip publik berubah sehingga merepotkan untuk pengguna FTP di server cpanel yang menggunakan CSF ini.

Untuk para Developer khususnya lebih cenderung menggunakan aplikasi FTP External semacam FilleZilla dibanding menggunakan FileManager Bawaan cPanel, tentunya dengan kondisi seperti ini sangat merepotkan.

Pesan error yang muncul ketika koneksi FileZilla :

Status: Resolving address of core.whmzen.netStatus: Resolving address of core.whmzen.netStatus: Connecting to 139.99.4.253:21…Status: Connection established, waiting for welcome message…Status: Initializing TLS…Status: Verifying certificate…Status: TLS connection established.Command: USER zenspwsResponse: 331 User zenspws OK. Password requiredCommand: PASS ******************Response: 530 Login authentication failedError: Critical error: Could not connect to server

Permasalahan tersebut penyebabnya ada di ‘Passive Mode’ yang tidak dapat port karena tertutup oleh firewall.

Untuk menagani permasalahan tersebut caranya yaitu dengan cara :

1. Tambahkan Port Passive range 49152 65534 ke file konfigurasi Pureftp Anda

nano /etc/pure-ftpd.conf

Isi Passive Port Range dengan port 49152 65534

PassivePortRange 49152 65534

dan Force Passive IP dengan ip server anda :

ForcePassiveIP 139.99.4.253

Kemudian restart pure ftp dengan perintah :

/usr/local/cpanel/scripts/setupftpserver pure-ftpd –force

2. Buka port  49152: 65534 di file konfigurasi firewall CSF Anda pada bagian TCP_IN. Masuk ke WHM cPanel anda, Pilih Menu ConfigServer Security & Firewall ->ConfigServer Firewall->Firewall Configuration->IPv4 Port Settings

Klik Change dan lanjutkan dengan restart FTP.

Silakan lakukan koneksi FTP kembali menggunakan FileZilla

Status: Resolving address of core.whmzen.netStatus: Resolving address of core.whmzen.netStatus: Connecting to 139.99.4.253:21…Status: Connection established, waiting for welcome message…Status: Initializing TLS…Status: Verifying certificate…Status: TLS connection established.Status: Logged inStatus: Retrieving directory listing…Status: Directory listing of “/” successfulStatus: Connection closed by server

anda berhasil menggunakan FTP FileZilla

 

Referensi : https://documentation.cpanel.net/display/CKB/How+to+Enable+FTP+Passive+Mode

curl_exec() has been disabled for security reasons

Published on September 9, 2017, by in Tutorial.

Judulnya langsung tampilan error yang muncul ketika curl tidak aktif yaitu :

Warning : curl_exec() has been disabled for security reasons …

Tampilan tersebut diatas menggunakan *kode php berikut :

<?php
// create a new cURL resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, “http://www.google.com/”);
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close cURL resource, and free up system resources
curl_close($ch);
?>

hal ini mengindikasikan kalau curl tidak aktif di server kita, lantai bagamana cara mengecek kalau curl di website kita aktif atau tidak ?

Kita gunakan function_exists php berikut :

<?php echo function_exists(‘curl_version’)?”CURL nya udah enabled”:”CURL nya masih terdisable”; ?>

function_exict tersebut akan memberikan pesan curl sudah enable atau tidak.

dan ternayata dicek sudah enable, akan tetapi tetap muncul warning curl_exec() has been disabled for security reasons

Lantas apa penyebabnya ? hal ini ternyata diakibatkan oleh curl_exec() yang berada pada disable_functions yang ada di file php.ini

Nah karena disini kita menggunakan cloudlinux dan multi php version jadi cukup banyak php.ini yang ada di server kita, karena ketika kita cek satu-satu di php-5.6 misalnya, pada disable_functions tidak terdapat curl_exec() alias kosong.

Bagaimana cara mencari php.ini yang bersisi curl_exec() pada disable_functions ini ? caranya yaitu kita gunakan scrip berikut, silakan copas pada terminal root anda :

find / -name “*.ini” -type f -exec grep -l “mail,exec,passthru,shell_exec” {} \;

Nah dengan perintah tersebut diatas, akan kita temukan posisi php.ini kita yang aktif. Perhatikan tampilan berikut :

[root@core ~]# find / -name “*.ini” -type f -exec grep -l “mail,exec,passthru,shell_exec” {} \;
find: ‘/proc/16067’: No such file or directory
/usr/share/cagefs/.cpanel.multiphp/opt/cpanel/ea-php56/root/etc/php.d/local.ini
/usr/share/cagefs/.cpanel.multiphp/opt/cpanel/ea-php55/root/etc/php.d/local.ini
/usr/share/cagefs/.cpanel.multiphp/opt/cpanel/ea-php70/root/etc/php.d/local.ini
/usr/share/cagefs/.cpanel.multiphp/opt/cpanel/ea-php71/root/etc/php.d/local.ini
/usr/share/cagefs-skeleton/opt/cpanel/ea-php55/root/etc/php.d/local.ini
/usr/share/cagefs-skeleton/opt/cpanel/ea-php56/root/etc/php.d/local.ini
/usr/share/cagefs-skeleton/opt/cpanel/ea-php70/root/etc/php.d/local.ini
/usr/share/cagefs-skeleton/opt/cpanel/ea-php71/root/etc/php.d/local.ini
/opt/cpanel/ea-php55/root/etc/php.d/local.ini
/opt/cpanel/ea-php56/root/etc/php.d/local.ini
/opt/cpanel/ea-php70/root/etc/php.d/local.ini
/opt/cpanel/ea-php71/root/etc/php.d/local.ini

Dari hasil pencarian tersebut diatas sudah jelas posisi file php.ini menajdi local.ini

Sekarang kita edit file local.ini satu-satu seperti yang tampil diatas :

nano /usr/share/cagefs/.cpanel.multiphp/opt/cpanel/ea-php56/root/etc/php.d/local.ini

Perhatikan tampilan berikut, terdapat curl_exec() pada disabled_function :

Hapus curl_exec() pada disable_functions menjadi seperti berikut :

Lakukan untuk file local.ini yang lain yang tampil pada pencarian tersebut.

Setelah selesai silakan cek kembali menggunakan *kode php diatas.

Selamat curl berhasil aktif pada server cpanel anda.

Merubah Owneship folder cPanel

Published on September 9, 2017, by in Tutorial.

Cara berikut sangat simple untuk mengubah permission folder.

Contoh pada gambar : http://zen.web.id/wp-content/uploads/2014/06/apache-install-1024×446.png

jika ownership nya adalah nobody:nobody maka gambar tersebut tidak bisa diakses.

Untuk cek ownership silakan menggunakan perintah berikut :

ls -l wp-content/uploads/2014/06/apache-install-1024×446.png

pada hasil cek ownership adalah nobody:nobody

maka kita rubah menjadi ewnership zenweb dengan cara :

sudo chown -R zenweb:zenweb wp-content/uploads/2014/06/apache-install-1024×446.png

silakan cek kembali dengan perintah :

ls -l wp-content/uploads/2014/06/apache-install-1024×446.png

Ownership menjadi

-rw-r–r– 1 zenweb zenweb 242717 Apr 29 2016 wp-content/uploads/2014/06/apache-install-1024×446.png

maka owneship akan berubah menjadi zenweb dan file gambar bisa ditampilkan.

demikian tulisan singkat ini, semoga bermanfaat.

CSF Firewall Manager di WHMCS

Published on September 1, 2017, by in Tutorial.

Sesuai judul CSF Firewall Manager di WHMCS.

Setelah kita install csf di server cpanel kita, tentunya belum lengkap tanpa dilengkapi CSF Firewall Manager di WHMCS billing system kita. Karena nantinya ketika ada clietn yang terblokir IP Publiknya, kita tidak usah repot melakukan manual Allow IP Adress supaya blokirnya terbuka kembali, tetapi client bisa melakukannya sendiri melalui panel client whmcs.

Langkah pertama silakan download file CSF Firewall Manager

Ekstrak file CSF Firewall Manager yang telah kita download tadi.

Upload folder “csfmanager” (seperti) ke dalam installer WHMCS Anda. Setelah diupload, path lengkap ke modul harus: “modules / addons / csfmanager”.

Login ke WHMCS Anda sebagai pengguna admin, dan arahkan ke “AddOn”

Temukan modul “Jetserver CSF Manager”, dan aktifkan.

Sekarang kembali ke “Jetserver CSF Manager”, klik Menu “Settings” Pilih Server yang akan diaktifkan pada CSF Firewall Manager ini.

Kembali ke Firewall Manager, Pilih Server yang akan dikonfigurasi

Klik “Select Server”

Kita bisa mengkonfigurasi CSF di Panel Billling WHMCS Kita

 

Pada client aktif, CSF Firewall Manager berada pada produk terkait, dan ada pada menu Manage Firewall widget seperti berikut :

Demikian turorial singkat CSF Firewall Manager di WHMCS. Semoga bermanfaat.

Disable notifikasi Alert CSF

Published on August 24, 2017, by in Tutorial.

Terkadang bagi sebagian orang merasa risih muncul notifikasi secara terus menerus yang masuk ke email dari CSF. Kita disable saja notifikasi tersebut, caratanya sebagai berikut :

Login ke WHM

Masuk Ke Plugin–>ConfigServer Security & Firewall –> Config Server Firewall –>Firewall Configuration

Sub menu Login Failure Blocking and Alerts –> LG_EMAIL_ALERT ubah menjadi off

Kemudian Klik Change

Akhiri dengan Restart CSF +LFD

demikian, semoga bermanfaat

Cara install CSF dan LFD di WHM/cpanel

Published on August 17, 2017, by in Tutorial.

Pada kesempatan kali ini akan kita bahas bagaimana cara installasi CSF (Config Server Firewall). Bagian yang paling menarif pada CSF ini adalah kita dapat mengkonfigurasi pada WHM kita juga dapat menganalisa dan mengevaluasi tingkat keamanan server cpanel kita .

Untuk Install Config Server Firewall kita ikuti langkah berikut :

cd /tmp
rm -fv csf.tgz
wget https://download.configserver.com/csf.tgz
tar -xzf csf.tgz
cd csf
sh install.sh
sh /etc/csf/remove_apf_bfd.sh

Setelah proses instalasi tersebut, kita harus lakukan langkah berikut :

  • buka WHM dan lanjutkan ke halaman Plugins -> ConfigServer Security & Firewall

  • Klik Configure Firewall dan set nilai TESTING ke Off

  • Ubah RESTRICT_SYSLOG menjadi 1

  • Pada paket VPS, set juga MONOLITHIC_KERNEL ke 1
  • Lanjutkan ke bawah dan tekan Change
  • Klik Restart csf + ldf
  • Kembali ke halaman ConfigServer Security & Firewall utama, opsi Quick Allow dapat digunakan untuk menambahkan IP ke tabel Allow agar tidak diblokir jika terjadi kegagalan login yang tidak disengaja dari alamat IP yang terpercaya.

Untuk menghapus penggunaan CSF

sh /etc/csf/uninstall.sh

Demikian, semoga bermanfaat.